Online font converter

Important: posts that do not use this template will be ignored or closed.

Before posting

  • Get familiar with Markdown to format and structure your post
  • Be sure to update lvgl from the latest version from the master branch.
  • Be sure you have checked the relevant part of the documentation. We will not respond in detail to posts where you haven’t read the relevant documentation.
  • If applicable use the Simulator to eliminate hardware related issues.

Delete this section if you read and applied the mentioned points.


The website can’t include another font
I want use two type font int my text,but I find the button “Include Another Font” can’t click in the website.

What MCU/Processor/Board and compiler are you using?

visual studio

What LVGL version are you using?


What do you want to achieve?

one C array file contains two type font

What have you tried so far?

the “Include another font” button clicked with noting effect

Code to reproduce

Add a code snippet which can run in the simulator. It should contain only the relevant code that compiles without errors when separated from your main code base.

The code block(s) should be formatted like:

/*You code here*/

Screenshot and/or video

If possible, add screenshots and/or videos about the current state.

There must be something up with your Internet connection… I went to the same link, clicked the “Include another font” button, and it works correctly for me.

Thank you very much I think so,but I tried many times and change the exploer and tried the wired and wireless internet,it still does not work,I don’t how to deal with it.


I tested in

  • Microsoft Edge Chromium Version 84.0.522.44 (Official build) beta (Windows 10, 64-bit) -> button works
  • Microsoft Edge 44.18362.449.0 (Windows 10, 64-bit) -> button works
  • Chrome Version Version 84.0.4147.105 (Official Build) (Windows 10, 64-bit) -> button works

Can you press F12 after the button fails to work, press Console, and send a screenshot of what is displayed?

Microsoft Edge 2020-07-29 22-09-25

It may means can’t connect with the server

Thank you very much,I tried in
Microsft Edge 44.18362.449
Chromium double cores
google Chromium 77.0.3865.120
360 exploer
All of them are 64 bit.but none of them works.

Looks like it failed to load some components which are needed. Perhaps they are blocked by your connection. They do seem to load for both @BesitzeRuf and I, so I suspect it’s something on your end.

You could try using the offline font converter instead.

Thank you I will try.