Glyph Additions

Backspace and Paste (f0ea) would be great (We already have cut and copy)

I’ve added them to dev-6.1. See this comment.

Do you mind for more symbols ?

LV_SYMBOL_EYE_OPEN (0xF06E, “\xef\x81\xae” )
and LV_SYMBOL_EYE_CLOSE (0xF070, “\xef\x81\xb0”)
for using at password-mode textarea for showing /hidden password ?

Thank you.

A symbol with bpp = 4, size = 16 pt is ~80 byte. As it is consumed from the flash I’m not against to add some symbols.

I saw an SD card symbol which also might be useful.

Lvgl can create to a binary font file and using from sd card instead of c lvgl font file?

You da man. That’s on my goals for the Ui designer, the ability to easily add/edit fonts

It’s not supported now, however, the fonts interface is quite abstract to implement it similarly to the current format.

If you are interested take a look at

USB might be another useful symbol.

1 Like

Hmm, I took 6.1 font dir. Seems LV_SYMBOL_TRASH is messed up, as it is showing as blank.

LV_SYMBOL_PASTE is showing blank as well (In roboto_12)

Both LV_SYMBOL_TRASH and LV_SYMBOL_PASTE is working for me. Do use the latest dev-6.1 branch?

Yes, but something is odd… And I am not sure exactly what it is. Occasionally I get no text at all, all text is blank

I’m having a worse variation of that issue. I see no text and the buttons are shrinking to minimum size (as if the label was never created).

Hmm, that’s strange. All works fine for me.

Maybe clean, re-index and rebuild?

I think I tried that, but I’ll do it again. :slight_smile:

I did try it (First thing I tried), and did it on 2 different machines.

What happens if you generate a new font without symbols and replace lv_font_roboto_16 with it?

I regenerated Roboto at size 20 without including FontAwesome. It worked with the latest dev-6.1.

Were the built-in fonts recreated using the new convertor that supports compression or the old convertor?

I’ve used the online converter which still uses the “old” converter. The only change is that I’ve used a custom FontAwesome font. See this comment.

In dev-6.1 I’ve added the following symbols:

  • USB

Do you still see the not-displayed-texts issue?
If so do you get warning log messages? (LV_USE_LOG and LV_LOG_PRINTF should be enabled in lv_conf.h)

I will try it when I get to work. That being said, is there any chance I could pick your brain on adding font editing to the GUI editor?