Disabling LV_BUILD_EXAMPLES in lv_conf.h but still it gets build

I have disabled macro LV_BUILD_EXAMPLES in lv_conf.h but still. When i do cmake in build directory and perform make it generates lv_eamples library. I have tried disabling some widgets option also in lv_conf.h and they are also getting compiled for lvgl library. The lv_conf.h is kept parallel with lvgl directory as per documentation. I feel like its not considering lv_conf.h properly. Is there something which I am missing. I have kept color depth 16 in conf.h and it looks like it has considered that property.

Thankyou in advance!
Note: I am using v8.3

did you edit the correct lv_conf file? I believe there are 2 of them

There is only one in my environment. Which I had copied “lv_conf_template.h” and renamed it to lv_conf.h and enabled #ifdef

I am sorry for wasting time. The path for lv_conf.h was not correct. I found my mistake.
But even after placing it in correct path. The liblvgl_examples.a is getting created

You have to look around, There is another config file somewhere that is being accessed by the compiler.

Sorry I forgot to update. It had to be disabled in env_support/cmake/custom.cmake