Chinese is not displayed

Important: posts that do not use this template will be ignored or closed.

Before posting

  • Get familiar with Markdown to format and structure your post
  • Be sure to update lvgl from the latest version from the master branch.
  • Be sure you have checked the relevant part of the documentation. We will not respond in detail to posts where you haven’t read the relevant documentation.
  • If applicable use the Simulator to eliminate hardware related issues.

Delete this section if you read and applied the mentioned points.


What MCU/Processor/Board and compiler are you using?


What do you want to achieve?

Chinese display

What have you tried so far?

used lv_font_simsum_16_cjk * Also cannot display Chinese, * * But everything else is displayed normally. * * Is there a problem with the Chinese character database? * What does this need to change? “lv_conf.h”

Code to reproduce

Add a code snippet which can run in the simulator. It should contain only the relevant code that compiles without errors when separated from your main code base.

The code block(s) should be formatted like:

/*You code here*/

myFont.txt (5.5 KB)

Screenshot and/or video

If possible, add screenshots and/or videos about the current state.


  • The problem has been solved. The following code


You can use other font libraries, such as freetype. The native library seems to have poor support for Chinese.