Source files for built in symbols

I have been working with lvgl 5x and have it implimented in a number of different embedded projects.
I recently tried version 6, firstly running the simulator and running the demo’s, but none of the symbols that should be on the demo (LV_SYMBOL_FILE,…,LV_SYMBOL_GPS) are being displayed. I have looked for them in the source tree but they seem to be missing. On with lvgl v5x the symbols were in lv_font_symbol_10/20/30/40,
Am I missing something or is there another location that they need to be obtained from ?

The font system was heavily rewritten in v6.0 and the symbols are now part of the builtin fonts. Are you testing it with the builtin lv_font_roboto_xx series?

Yes, I am testing with code downloaded from the master branch on Github (V6.0). Which has lv_font_roboto_xx and lv_font_unscii_8, but no symbol font source files in the font directory int he source tree.

That’s because the symbols are now part of the Roboto fonts (like I said above). There are no separate source files for symbols anymore.

Are you trying this with one of the Roboto fonts or a different font?

Ok thanks understood,
I have the following in lv_conf.h

/* Robot fonts with bpp = 4
 *  */
#define LV_FONT_ROBOTO_12    1
#define LV_FONT_ROBOTO_16    1
#define LV_FONT_ROBOTO_22    1
#define LV_FONT_ROBOTO_28    1

/*Pixel perfect monospace font
 * */
#define LV_FONT_UNSCII_8     1

/* Optionally declare your custom fonts here.
 * You can use these fonts as default font too
 * and they will be available globally. E.g.
 *                                LV_FONT_DECLARE(my_font_2)

/*Always set a default font from the built-in fonts*/
#define LV_FONT_DEFAULT        &lv_font_roboto_16

Running the demo_create app on Visual Studio, text is shown on the button list items, but no symbols.

Do you have the latest master commit on the Visual Studio repository itself (d6596b9)? There was an issue with symbols there but it should be fixed now.

Hi Have just downloaded the latest VS repo as well as that for lvgl itself and am getting the same result after a complete new build.

Thanks, I must have mixed up old and new repo’s. I started again with the latest repos and it is now working.


I must have mixed up old and new repo’s.

No problem; a simple git log usually reveals the mistake pretty quickly. (I’ve been there. :wink: )