SDL TFT simulator disappearing immediately

I am running current lv_micropython and when I run examples, I only see a brief flash of the “TFT Simulator” and it then exits (with exit status 0). Am I doing something wrong?

What worked for me was to build VARIANT=dev (includes uasyncio) and run the, or after adding uasyncio. Perhaps it is a hint for someone.

Just a note, as there are crashes reported for SDL display, I do not have an nVidia card.


When you start lv_micropython from command line with a script argument, it runs the script and exits.
If you would like to keep the REPL open, add -i command line argument before your script argument.

If you don’t want the REPL, just make sure your main script doesn’t exit before you actually want to close the window.

That’s because uasyncio runs an event loop that blocks everything until it completes. Without uasyncio, LVGL event loop is running only as long as the script is running.

1 Like

Thanks for the reply :+1: I realized shortly after I posted that this might be a problem.