Reminder: display of Chinese characters


I find that many people encounter the same problem as me, and they can’t display Chinese characters normally in vs simulation. I use vs2019. During the simulation, Chinese characters can’t be displayed all the time. It can be displayed by filling the array with Unicode code directly, which should be the problem of compiler. Today, I found out by accident that it’s OK to change the eclipse simulation, the same code. I hope it will be useful to you.

1 Like


There should be a setting in VS to change the default encoding. It means how the IDE encodes the strings you enter. It should be UTF-8.

See this:

It’s really a coding problem. Instead, utf8 without BOM can be displayed, but only double number Chinese characters can be displayed. Otherwise, vs reports a syntax error. This should be due to vs’s own problems. I see the same hint in an open source project.

Hello,I’m very exciting seeing your topic about Chinese font input,I even use the online font convert tool,I add the font c document in my program with uTF8 and change the visual studio IDE in unicode ,but it still display nothing.I don’t konow why.