Problem building SDL demo on VSCode + PlatformIO


Been trying to get the “littlevgl/pc_simulator_sdl_platformio” project working on my Macbook using the VSCode + Platform IO project with little success.

I already had VSCode with PlatformIO installed for some Arduino projects and there it works flawlessly.

When I run build the output is the following:

Processing native (platform: native)
Verbose mode can be enabled via -v, --verbose option
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 2 compatible libraries
Scanning dependencies…
Dependency Graph
|-- 6.0
|-- <littlevgl_sdl_drivers> 1.1
Compiling .pio/build/native/src/demo.o
Compiling .pio/build/native/src/img_bubble_pattern.o
Compiling .pio/build/native/src/main.o
Compiling .pio/build/native/lib72b/littlevgl_ID6228/lv_core/lv_disp.o
In file included from src/demo.c:9:
include/demo.h:18:10: fatal error: ‘lvgl.h’ file not found
#include <lvgl.h>
1 error generated.
src/img_bubble_pattern.c:2:10: fatal error: ‘lvgl.h’ file not found
#include <lvgl.h>
*** [.pio/build/native/src/demo.o] Error 1

I’ve tried running “Update project libraries” to no avail. The dependent libs(lvgl and the sdldrivers) are located in .pio/libdeps/native.

I’m sure I’m just missing something simple but I’m just not seeing it, everything is there but the project env. just doesn’t seem to be able to find it using the steps in the repo.

In contradiction to our usual “use the forum” policy, please open an issue at, because the PlatformIO maintainer (puzrin) doesn’t appear to have a forum account.

Will do, thank you for a quick reply.

@embeddedt i have commit permissions, but do not maintain that repo. It has a lot of experimental garbage, and need full rework, including name, to be useable. That’s all need to be discussed.

I still not use lvgl (do other things), and planned to dive into when “settings menu” moves forward.

So, i can help with questions about PIO & configs, but not about C code builds. Branch vit there works, because has pinned lvgl version to 5.3

@kisvegabor has an initial demo working.

I’ve push a lot of improvements to the app. Let me know what do you think in the GitHub issue.