Online image converter problem


Online image converter fails to generate good binary images

What MCU/Processor/Board and compiler are you using?


What do you experience?

I select an image in the online image converter, choose a binary output format and click convert. The resulting .bin file is only 5 bytes long. It does not seem to matter the type or format of the input image.

Selecting a .c file output works as expected.

What do you expect?

File containing encoded binary image.

Code to reproduce

Windows 10, Firefox and Edge both fail.

Screenshot and/or video

If possible, add screenshots and/or videos about the current issue.

Please attach a file to reproduce the issue and a screenshot about the settings of the converter.

Thanks for the prompt reply. Here is an example of an image I am having trouble with…

One image per post. Stand by…

When I try these settings…

The result is:

Note the file size is 5 bytes.


I’ve fixed it and tested with you image.

Yes it works now. Thank you for attending to this so promptly. LittlevGL rocks!

1 Like