Lvgl_esp32_drivers compatibility

Description

I the lvgl_esp32_drivers realy to use with lvgl release 8.3 and with esp-idf v5.0.1 version. It seems that it needs update cause several problems exists on build

you can check this for changes identified. It could be that it is not the proper way but at least it is some way to make initial build not to fail