LV_SYMBOL_TRASH shows blank in a button

What MCU/Processor/Board and compiler are you using?


What LVGL version are you using?


What do you want to achieve?

LV_SYMBOL_TRASH in a button

What have you tried so far?

other symbols work well, just this one is not showing at all and i need that

Code to reproduce

Add a code snippet which can run in the simulator. It should contain only the relevant code that compiles without errors when separated from your main code base.

The code block(s) should be formatted like:

/*You code here*/

it is properly defined, other symbols do show, it is at F2ED in the font file

#define LV_SYMBOL_BATTERY_EMPTY “\xef\x89\x84” /62020, 0xF244/
#define LV_SYMBOL_USB “\xef\x8a\x87” /62087, 0xF287/
#define LV_SYMBOL_BLUETOOTH “\xef\x8a\x93” /62099, 0xF293/
#define LV_SYMBOL_TRASH “\xef\x8B\xAD” /62189, 0xF2ED/
#define LV_SYMBOL_BACKSPACE “\xef\x95\x9A” /62810, 0xF55A/
#define LV_SYMBOL_SD_CARD “\xef\x9F\x82” /63426, 0xF7C2/

lv_obj_t * btn31 = lv_btn_create(tabpresets, NULL);
lv_obj_add_style(btn31, LV_LABEL_PART_MAIN, &btn_style1);
// lv_obj_set_event_cb(btn31, event_gotomaxbottom);
label = lv_label_create(btn31, NULL);
lv_obj_add_style(label, LV_LABEL_PART_MAIN, &label_style3);
lv_label_set_text(label, LV_SYMBOL_TRASH);
lv_obj_set_width(btn31, 55);
lv_obj_set_height(btn31, 55);
lv_obj_align(btn31, NULL, LV_ALIGN_IN_TOP_RIGHT, -100, 80);


Screenshot and/or video

If possible, add screenshots and/or videos about the current state.

answering my own question then :slight_smile:
it does show up with a smaller style fontsize, i change the font for the button from roboto to monserrat and presto, the icon is there, no clue why only the bin icon shows up blank while the others do show
but anyway, problem looks solved…back to the other problems…