Lv_demo_printer not working in my board

Hi Team,

i updated LVGL version to 7.0+ and build success with out any errors and warnings.

when try to run the code in my board i have not seen any GUI on my board.

version 6 code working fine on my board. should i do any changes ?

i am attaching main.c file
main.c

#include "lvgl/lvgl.h"
#include "lv_drivers/display/fbdev.h"
#include "lv_drivers/indev/evdev.h"
#include "lv_examples/src/lv_demo_printer/lv_demo_printer.h"
#include <unistd.h>
#include <pthread.h>
#include <time.h>
#include <sys/time.h>
#include "lv_drivers/indev/mouse.h"
#include "lv_drivers/indev/mousewheel.h"
#include "lv_drivers/indev/keyboard.h"
#define DISP_BUF_SIZE (LV_HOR_RES_MAX)

int main(void)
{
    /*LittlevGL init*/
    lv_init();

    /*Linux frame buffer device init*/
    fbdev_init();


    evdev_init();
    /*A small buffer for LittlevGL to draw the screen's content*/
    static lv_color_t buf[DISP_BUF_SIZE];

    /*Initialize a descriptor for the buffer*/
    static lv_disp_buf_t disp_buf;
    lv_disp_buf_init(&disp_buf, buf, NULL, DISP_BUF_SIZE);

    /*Initialize and register a display driver*/
    lv_disp_drv_t disp_drv;
    lv_disp_drv_init(&disp_drv);
    disp_drv.buffer = &disp_buf;
    disp_drv.flush_cb = fbdev_flush;
    lv_disp_drv_register(&disp_drv);


        lv_indev_drv_t indev_drv;
        lv_indev_drv_init(&indev_drv);
        indev_drv.type = LV_INDEV_TYPE_POINTER;
        indev_drv.read_cb = evdev_read;
       // lv_indev_t * mouse_indev = lv_indev_drv_register(&indev_drv);


        /*LV_IMG_DECLARE(mouse_cursor_icon);
        lv_obj_t * cursor_obj =  lv_img_create(lv_disp_get_scr_act(NULL), NULL);
        lv_img_set_src(cursor_obj, &mouse_cursor_icon);
        lv_indev_set_cursor(mouse_indev, cursor_obj);*/
        void lv_demo_printer(void);
    /*Create a Demo*/

       lv_demo_printer();
    /*Handle LitlevGL tasks (tickless mode)*/
    while(1) {
        lv_task_handler();
        usleep(5000);
    }


    return 0;
}

/*Set in lv_conf.h as `LV_TICK_CUSTOM_SYS_TIME_EXPR`*/
uint32_t custom_tick_get(void)
{
    static uint64_t start_ms = 0;
    if(start_ms == 0) {
        struct timeval tv_start;
        gettimeofday(&tv_start, NULL);
        start_ms = (tv_start.tv_sec * 1000000 + tv_start.tv_usec) / 1000;
    }

    struct timeval tv_now;
    gettimeofday(&tv_now, NULL);
    uint64_t now_ms;
    now_ms = (tv_now.tv_sec * 1000000 + tv_now.tv_usec) / 1000;

    uint32_t time_ms = now_ms - start_ms;
    return time_ms;
}

Output on Board:

Thanks in Advance.

Only the printer demo is not working?
Can you just create a few simple object (button, label, etc)?

Yes Only Printer Demo is not working.

created simple objects its working

Try to increase LV_MEM_SIZE in lv_conf.h.