It's not really bug, wish lv_chart_get_point_cnt() and lv_chart_set_point_count() rename to the same look-alike name

Between get / set functions in lv_chart’s api :
lv_chart_set_point_count(...) and lv_chart_get_point_cnt(...)

Wish change the api names are look-alike
such as
lv_chart_set_point_count(...) and lv_chart_get_point_count(...)
lv_chart_set_point_cnt(...) and lv_chart_get_point_cnt(...)

Sorry for my poor english to explaination.

We can probably rename it in 7.0 with a define to preserve the old name.

1 Like

Good catch!
I’ve just renamed it and added lv_api_map.h to define the old API too.

1 Like