Issues with evdev input on linux


no input from evdev, touchscreen is setup and working and input is detected with evtest (identifying touchscreen at /dev/input/3

note: program is in C++

What MCU/Processor/Board and compiler are you using?

Linux SBC with a touchscreen

What LVGL version are you using?


What do you want to achieve?

get input from touchscreen

What have you tried so far?

used code from existing linux fb repo, but was not working
predicting it to be error in the lv_drv_configuration

Code to reproduce

my code is up on github for testing:

I see you changed lv_drv_conf to reflect the correct path. Did you clean and fully rebuild afterwards? Some build systems don’t pick up the change automatically.

yes, I did fully clean up the build and recompile, but I still no touch.
by any chance could a previously installed compositor or other DE related things be messing with it ?
I will try using a fresh install to rule out such scenarios

so I done some testing, and I’m still unable to get it working
do you have any other ideas as to why it might not be working @embeddedt ?

Not at the moment. I’d suggest using GDB and setting breakpoints here and in evdev_read to confirm that the right device is being used.

If you touch the screen while GDB is paused you should at least get into the body of the while loop in evdev_read, even if it happens to be an unsupported event type. If that doesn’t happen, something else is wrong.

1 Like

I just made it work by using the lvgl, lv_drivers snapshot provided in

now it works, pardon for the confusion that may have arisen :slightly_smiling_face:

1 Like