I'm trying to upgrade lvgl from 7.6.1 to 8.0 but I have faced some issue

I use zephyr RTOS and work on STM32F429 board.
as you guys know, lvgl 7.6.1 version is migrated in zephyr(2.6.99).
so, I try to upgrade lvgl library from 7.6.1 to 8.0 referencing below url

step 1. copy lvgl(8.0) to zephyrproject/modules/lib/gui folder
step 2. copy lv_conf_template.h which is in lvgl(8.0) to this path (zephyrproject/zephyr/lib/gui/lvgl) and change the file name to lv_conf.h
step 3. change to #if 1 in lv_conf.h
step 4. fix build error building test application.

so. I success the build and flash binary my board ( stm32F429… )

but I had faced below error.

[00:00:00.131,000] 31m os: ***** USAGE FAULT *****
[00:00:00.131,000] 31m os: Illegal use of the EPSR
[00:00:00.131,000] 31m os: r0/a1: 0x20018420 r1/a2: 0x200183e8 r2/a3: 0x080280f6
[00:00:00.131,000] 31m os: r3/a4: 0xfffffffe r12/ip: 0x00000000 r14/lr: 0x0800538d
[00:00:00.131,000] 31m os: xpsr: 0x60000000
[00:00:00.131,000] 31m os: Faulting instruction address (r15/pc): 0x080280f6
[00:00:00.131,000] 31m os: >>> ZEPHYR FATAL ERROR 0: CPU exception on CPU 0
[00:00:00.131,000] 31m os: Current thread: 0x20000230 (unknown)
[00:00:00.187,000] 31m os: Halting system

currently, I have no idea what I should do.
please give me an opinion to solve this issue.


Did you make the necessary driver changes (most importantly, changing them to static or something which will not go out of scope)?

Thanks for commment.
From the migration guide, I did do it like below.

  • lv_disp_drv_t, lv_indev_drv_t, lv_fs_drv_t needs to be static
  • ...disp_buf... is renamed to draw_buf. See an initialization example

Is there anything I missed?

Opps. I have solved this one. when I ran the below command. the change which I modified some variable to be static in driver level was removed.

git checkout -f ( -_-)a
I added this change again and it works well. lol

thanks for reminding me
Best Regards