How to use codeblocks simulator?


What MCU/Processor/Board and compiler are you using?

Codeblocks MinGW 17.12

What do you want to achieve?

Run simulator on windows.

What have you tried so far?

Download simulator from
Run LitllevGL.cbp

My problem

I get a grey screen when I click on LitllevGL.cbp. I don’t know what to expect. According to all the material available you just have to click on LitllevGL.cbp.

Can you please provide some steps to get it running ?

Screenshot and/or video

You have to click the button that looks like a gear and grey arrow combined. That builds and runs the application.

If you’re talking about the build and run icon then I have tried it already.

This is the output.

It seems to me that it is not picking up on the build settings (e.g. complaining about C90 mode when it should be set to C99).

Did you change any settings when you opened the project? Are you using the latest version of CodeBlocks?

I haven’t looked at the project in a while so it’s possible that something is broken.

Nope, there is nothing wrong with the GitHub project on my side. Just tested it now:

  1. git clone --recursive
  2. Opened the LittlevGL.cbp file in that folder.
  3. Clicked the build and run icon.

The simulator appeared without any issues, so this must be an issue on your end. Did you clone a fresh version of the project with submodules (--recursive)? Is this a fresh CodeBlocks installation?

Thank you very much. LittlevGL is awesome and you all are very helpful.

I opened compiler settings on my CodeBlocks and reset my settings to default and it is working fine now.
Earlier when it was not working I had deleted and reinstalled the latest version of CodeBlocks so I thought that every setting must have been reset. Seems like I was wrong.

It will be helpful for others if you could write a few steps in the GitHub repo.

I updated the README.