How to add custom symbol to my fonts

Hi All,

I am trying to migrate from ver5.3 to ver6.0. I had created my own symbol in ver5.3, since I need some custom symbol so I can not use fontAwesome symbols. Previously in ver5.3 I had created my symbol font files and then using lv_font_builtin_init added my symbols to my custom fonts. I noticed that there is no lv_font_builtin_init function any more. I tried to use font converter and added my font file (( e.g robotbold.ttf) ) first then added my symbol font files but it keeps give me an error “doesn’t have any characters included in range 0xEA-0xF1” while I was able to install the font file which includes the my symbols in windows and I am sure about the symbols Unicode .


Just to be sure check in FontForge if really there are characters in that range.


Yes actually I used the FontForge and edited the symbols unicodes. How can I upload the font here, since I am new user it doesn’t allow me to upload a file?

I tested the ttf file with old converter(ver5.3) and worked fine but with the new converter it keeps giving me the following error:
Font “NLTHomeIconsV3Regular.ttf” doesn’t have any characters included in range 0xf293-0xf2bc

I gave permission to send attachment.

Thanks, I’ve already uploaded that in git. However, I’ve attached (4.4 KB)

Just for the sake of completeness here is the mentioned GitHub issue