Error when making the files using ESP-IDF v4.4 and the default branch of LV_MICROPYTHON

I got an error when making the files using ESP-IDF v4.4 and the default branch of lv_micropyhton.
First, I open my terminal and active the ESP-IDF with the command:

. $HOME/esp/esp-idf/

After that, I go to my lv_micropyhton folder, open the ports/esp32 directory and run the following command:

make submodules

And when a run:


This problem shows up:

I got a different problem when using the LTS version of ESP_IDF too, and instead of using the make command I also tried running “ build” direct and I got the same problem above.

I don’t think that this matters now, but I’m working on an esp32, with an ili9488 display driver and the ft6x36 touch driver from MAKERFABS.

Someone could show me what I can try to this simple step??

I tried all from the beginning again with lv_micropython, but this time I tried with the UNIX port as they teach on git hub and I had some issues too.
When I run the command:

  1. make -C ports/unix

I got this:

Before this command, all the others worked fine:

Before commands:

  1. sudo apt-get install build-essential libreadline-dev libffi-dev git pkg-config libsdl2-2.0-0 libsdl2-dev python3.8 parallel
  2. git clone
  3. cd lv_micropython
  4. git submodule update --init --recursive lib/lv_bindings
  5. make -C mpy-cross
  6. make -C ports/unix submodules

Ok, after some work I discover that the problem was the ubuntu version. So now I’m using ubuntu 20.04 and esp-IDF v4.4 and all is working fine with lv_micropython.