Change resolution for the simulator makes it nonresponsive


I tried changing the resolution for the simulator in visual studio code under Linux, the simulator stops responding

What MCU/Processor/Board and compiler are you using?

I’m using the simulator with Visual Studio code under Linux, using the github repo

What do you want to achieve?

The default resolution is 480 * 320, I’m trying to design a UI for a screen with resolution 480 * 272, I’m trying to change the resolution to 480 * 272

What have you tried so far?

I have changed lv_conf.h

Code to reproduce

I changed the following lines in lv_conf.h to match what’s needed for my board (according to the STM32F746 port github repo):

/* Maximal horizontal and vertical resolution to support by the library.*/
#define LV_HOR_RES_MAX          (480)
#define LV_VER_RES_MAX          (272)

//Some other code
#  define LV_MEM_SIZE (32 * 1024)

I get the following output in the console:

Warn: Couldn't allocate memory  (lv_mem.c #208 lv_mem_alloc())
Warn: Couldn't allocate memory  (lv_mem.c #323 lv_mem_realloc())
Error: lv_table_set_row_cnt     (lv_table.c #314 lv_table_set_row_cnt())
Error: Out of memory (0x0000000000000000)       (lv_debug.c #127 lv_debug_log_error())

The resolution is correct for the simulation window, however it doesn’t show anything and when I try to close it the system says it’s not responding
Is there something else I need to fix on the code?
Thank you