Atomic.h: No such file or directory

I am using a WT32-SC01 with ESP32WROVER, Arduino IDE v2.3.2, LVGL library v8.3.11 and a gui designed on Squareline Studio 1.4.0

I have made a few changes to the .ino file - absolutely nothing at all to do with the gui side, just added in a DS18B20 sensor reporting back via serial ie not displaying on the gui and now it will not compile which it did before. I get the following error message;

c:\Users\Baart\OneDrive\Documents\Arduino\libraries\lvgl\src\osal\lv_freertos.c:19:10: fatal error: atomic.h: No such file or directory

I have actually tried going back to the original sketch from a zip file, archived some weeks ago when all was working properly and I get the same error so it is nothing to do with my sketch modification.

So, either for some reason atomic.h has disappeared from my system, or it now wants to include it where previously, it didn’t. I am not posting the code because as it WAS working and now doesn’t, there is no point anyone looking at it.

Can anyone suggest a fix? Thank you.