Application Runs, but GUI doesn't show


I’m trying to get familiar with LittlevGL and trying to get the tutorial to run on my desktop before I start working with the STM32 board. I’ve used the examples and tutorials to created a project for Visual Studio Code on linux using SDL2 (I added a CMakeLists.txt file to make it easier). I get everything compiling and it runs, but the gui is not visible. I’ve enabled trace level logging, and I don’t see any failures. In my System Monitor I see the app running and I receive a memory task every 3 seconds (used: 10112 ( 31 %), frag: 1 %, biggest free: 22632). I’m guessing I’m missing something (probably dumb on my part), but no matter what I do the Windows don’t show.

What MCU/Processor/Board and compiler are you using?

Using Linux Ubuntu 18.04 with SDL2 2.0.10

What do you want to achieve?

I’d like to get this working on my Ubuntu machine

Code to reproduce

I added the application to as a github repo:

To run it you just need the following commands from the root of the project
mkdir cmake
cd cmake
cmake -DCMAKE_BUILD_TYPE=Debug …
make -j

Thanks for any help you can provide.


I’ve tested it on Linux Mint and it worked well for me.

What do you get in the terminal for sdl2-config?

When I run the command I get the following:

jebrando@desktop:~$ sdl2-config
Usage: /usr/local/bin/sdl2-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--cflags] [--libs] [--static-libs]

Thanks in advance

I have figured out the issue. When I ran SDL by itself without lvgl I was getting an error messages:

no video devices available

I uninstalled sdl2 package and installed it from source and it worked after that.


1 Like