Pc simulator linux\eclipse error cannot find -lpng


Getting a build error “/bin/ld: cannot find -lpng” using Eclipse CDT on Linux Mint20.02
I followed the install instructions verbatim and verified the Git repo, SDL is installed

What MCU/Processor/Board and compiler are you using?

PC simulator Linux Mint Eclipse 2021-06(v4.20.0)

What LVGL version are you using?

Repo: https://github.com/lvgl/lv_sim_eclipse_sdl.git
cloned via “git clone --recursive https://github.com/littlevgl/pc_simulator_sdl_eclipse.git

What do you want to achieve?

successfully build the pc simulator demo on Linux Mint using Eclipse CDT\SDL2

What have you tried so far?

I have tested to make sure SDL is installed, reports "libsdl2-2.0-0 is already the newest version 2.1.10+dfsg1-3
I double checked the git repo for the pre configured eclipse project is https://github.com/lvgl/lv_sim_eclipse_sdl.git and the command I used to recursively clone the repo was “git clone --recursive https://github.com/littlevgl/pc_simulator_sdl_eclipse.git
I tried a clean install of Linux and repeated the steps and got the same result.

Try installing libpng via sudo apt-get libpng-dev (though it is strange that compilation would succeed without it anyway). Or somehow the linker fails to find libpng.so in standard locations? For me it is (try dlocate libpng.so): libpng-dev:amd64: /usr/lib/x86_64-linux-gnu/libpng.so

That worked, libpng was not installed on my linux box. idk why I didn’t think to check that. :thinking:

@vkeiper glad it worked, this is something that should be mentioned in the docs. I proposed to add libpng-dev to the README.md file https://github.com/lvgl/lv_sim_eclipse_sdl/pull/98 . Cheers!