Got errors when using Visual Studio 2017


I tried to run GUI with PC simulator,but got erros.
Errors like this: visual_studio_2017_sdl\main.c(13): fatal error C1083: Cannot open include file: ‘lv_drivers/display/monitor.h’: No such file or directory

What MCU/Processor/Board and compiler are you using?

Visual Studio 2017

What have you tried so far?

I saw people said cope that "lv_drivers"folder files into that empty folder, but I don’t konw where are those “lost files”.

If you downloaded the ZIP file and extracted it, delete that and use git clone and git submodule update --init instead. GitHub’s ZIP files don’t contain submodules, for reasons unknown to me.

If you cloned the repository using Git, make sure to run the latter of my two commands to download submodules if you hadn’t done so already.

Got it,it works,but got some problem.
I tried " git clone --recurse-submodules" command and got all the files, also successfully workd on Visual Studio.
But I tried two commnds you told me firstly, and always missing the “lvgl” foler files, as it reported “unable to find current revision in submodule path ‘lvgl’”. I don’t know why.
This is my first time using “git” command to get files,so sorry I got many questions,thanks for your reply.