"glyph dsc. not found" Error when adding an arabic font

Some more infos:

I tried it today on real embedded hardware, not only on VS simulation.
Arabic characters are shown on my display!

Seems to be a problem of VS!?

My IDE is eclipse (and in addition I use notepad++ sometimes).
Arabic characters are shown in both editors the same and in RTL.
But eclipse needs UTF-8 with BOM! (Maybe VS needs BOM too?)
Except notepad++ (at least the version I’m running) has a little problem with correct insertion position when I paste a character into an RTL string.
The arabic strings are shown in notepad++ and eclipse in RTL, within my lvgl driven display it’s LTR. Does it need a specific setting?

The source file format matters, otherwise the C compiler inserts the wrong character codes and LVGL doesn’t know what to do with them.

thanks all for your time and efforts really appreciate it.
Many thanks
I solved the problem with VS and it goes like this.
you close the file and reopen it from the solution explorer by clicking right button and choosing open with
then this window will pop up
you should choose the selected option not the default one then OK.
and then choose auto-detect and that would solve the problem.

that being said

I am still facing a problem with the same font as It seems like there are no glyphs for the different positioning of the Arabic letters which is weird
because every online website offers you to test the font online and it works fine.
but I can’t get those letters in the .ttf file, their ranges are empty.

in another words
I only can output individual letter

أ ه ل ا

not a whole word


but the lv_font_dejavu_16_persian_hebrew
works fine

yes, look up at the lv_confg.h file for the LV_USE_BIDI macro and set it to 1

you can test the font yourself at google Fonts here

The DejaVu Hebrew font is converted using the following settings:

--size 16 -o lv_font_dejavu_16_persian_hebrew.c --bpp 4 --font DejaVuSans.ttf -r 0x20-0x7f,0x5d0-0x5ea,0x600-0x6FF,0xFB50-0xFDFF,0xFE70-0xFEFF

As long as you are using the exact same range it should work identically (unless TTF fonts store information about how to combine the letters??).

I don’t think the problem is in the ranges anymore, it is in the .ttf file it self
It doesn’t contain the ranges for the different shapes of letters Arabic Presentation Forms-B.
you can check it at https://fontdrop.info/
the site shows the glyphs with a Unicode of none :frowning:
but the type yourself option works fine despite that.

I don’t know how they work, this is my first time to encounter the .ttf files,
So I don’t get what you mean with the font stores information about how to combine the letters.

I just talked with the font developer and he stated that it is an open type font and having an open type engine is a must to be able to use it.
what a shame it is a very beautiful font.
and it has already all of the glyphs just not associated with the unicodes.

Finally, Got the Font fixed using FontForge
and here is the font file if anyone interested in the same font.
ReemKufi-Regular.zip (31.4 KB)
Thanks All. <3